Problem loading data for customers in AWS EU region
Monitoring·Partial outage

The AWS EU region is fully operational again. We are monitoring its performance and analyzing the root cause of the outage.

Tue, Aug 12, 2025, 03:14 PM
(4 days ago)
·
Affected components
Amazon Web Services (AWS) - eu-west-1
Updates

Monitoring

The AWS EU region is fully operational again. We are monitoring its performance and analyzing the root cause of the outage.

Tue, Aug 12, 2025, 03:14 PM

Identified

We have identified the cause of the problem and are now restoring service step by step.

Tue, Aug 12, 2025, 02:04 PM(1 hour earlier)

Investigating

We experience problems retrieving data for customers operating in our European AWS region. We are analyzing the root cause and will update as we go.

Tue, Aug 12, 2025, 01:16 PM(48 minutes earlier)