Resolved
The Clerk is reporting as fully operational, and their latency dashboard shows that the earlier degradation has stabilized.
Our validation indicates the customer impact was limited and is now resolved.
Monitoring
Our identity provider is experiencing performance degradation, which is causing slowness in our UI. See https://status.clerk.com/incidents/01M1ETFWW4XQH44X1SZY7RKR8R