Resolved
All services remained stable after mitigations were applied and we are closing the incident
Monitoring
Frontend availability has been restored and we keep monitoring the situation
Identified
We have identified the issue and are applying mitigations. The UI should be available again
Investigating
We are experiencing slowness and timeouts for UI users and are already investigating the issue