Resolved
Problem has been resolved.
Monitoring
The issue has been mitigated and we continue to monitor our systems before we fully resolve this incident
Identified
We have identified a delay in metric processing for a subset of metrics in our AWS Ireland region. We are already working on a fix